Platform Service Disruption
Incident Report for Veracode
Resolved
Between 2:31am EDT – 3:18am EDT on June 21, 2022, Veracode experienced a Platform service disruption due to a 3rd Party Vendor global outage. During this time, customers would have experienced 5xx related errors when attempting to access the Platform UI or utilizing various Platform APIs. The incident was resolved at 3:18am EDT once their incident was resolved and we saw our platform observability and monitoring return to normal levels. If you have any further questions or concerns, please open a ticket with Veracode Support at support@veracode.com.
Posted Jun 21, 2022 - 04:27 EDT
Monitoring
Our 3rd Party Vendor has implemented a fix to resolve the issue. We are continuing to monitor our systems closely at this time. Customers may sporadically experience 5xx errors until the issue is completely resolved.
Posted Jun 21, 2022 - 03:40 EDT
Identified
Veracode Engineering has identified the issue to an outage with one of our 3rd Party Vendors who is experimenting wide spread issues. We continue to work with the vendor to quickly resolve the issue.

The next update will be available by 3:45am EST.
Posted Jun 21, 2022 - 03:08 EDT
Investigating
Veracode Engineering is actively investigating increased error rates and latencies that is impacting reaching the Platform UI or utilizing various APIs.

If you have any further questions or concerns, please open a ticket with Veracode Support at support@veracode.com. Thank you for your patience as we actively work to resolve this issue.

The next update will be available by 3:30am EST.
Posted Jun 21, 2022 - 03:00 EDT
This incident affected: Platform, Results (/api/5.0/detailedreport.do, /api/5.0/detailedreportpdf.do, /api/4.0/summaryreport.do, /api/5.0/summaryreportpdf.do), Uploads (/api/5.0/getappinfo.do, /api/5.0/getapplist.do, /api/5.0/getbuildinfo.do, /api/5.0/getbuildlist.do, /api/5.0/uploadfile.do, /api/5.0/uploadlargefile.do), Mitigations (/api/getmitigationinfo.do), and Administration (/api/3.0/getuserinfo.do).